No sound in ut2003 or ut2004

Fabrice DELENTE fabrice.delente at
Sun Dec 9 10:20:37 EST 2007


I've tried all I could to have sound in ut2003 and ut2004, but nothing.

I installed these games on my laptop, an AMD64 TL60 2GHz double-core.

This laptop has an embedded soundcard, which works ok in ALSA; I bought an
external USB, that works ok too. I get sound in mplayer, xmms, wine, etc.

The USB card is defined as default in my ~/.asoundrc

After I installed ut2004, I got sound on the embedded card; I wanted it on
the USB one, so I created a ~/.openalrc with these lines:

# Contains user settings for OpenAL
# Goes in ~/.openalrc

# Which backend?  Tried in order of appearance
(define devices '(alsa sdl null))
(define speaker-num 2)
(define alsa-out-device "default")

After that ut2004 refused to start, it bombed out with a SIGSEGV.

I recompiled libopenal 0.0.7; I then symlinked to in /usr/local/games/ut2004/System, and the game starts now, but
with no sound at all, on neither of the soundcards.

I tried with openal 0.0.8, but got the same result.

The only lines I get in ~/.ut2004/UT2004.log are

Log: ALAudio: Using ALC_EXT_capture to record audio.
Exit: OpenAL Audio subsystem shut down.

Any hint?


More information about the ut2004 mailing list