[ut2004] ALSA sound without OSS emulation

Alex Malinovich demonbane at the-love-shack.net
Mon Mar 22 00:56:09 EST 2004

On Thu, 2004-03-18 at 19:35, Ryan C. Gordon wrote:
> > Correct, it's the retail version.
> >
> > Can you tell me more about what order UT searches for audio devices in?
> > I'm using udev, so devices get created as needed. If UT is checking for
> > a device that hasn't been automatically created by udev, it's possible
> > that it thinks that ALSA isn't enabled and is therefore going back to
> > OSS support.
> I believe it tries them in the order your .openalrc file requests, and
> ALSA can fail if the libraries don't load or (inside libasound) it can't
> open the device. I don't know what libasound does behind the scenes.

While this is certainly a rather substantial claim on my part, I'm
beginning to think that openal requires OSS support in ALSA. I had
thought that it was a misconfiguration on my desktop that was causing
the problems. Something between the combination of a 2.6 kernel, udev,
etc. So I decided to test it out on my laptop.

My laptop also uses ALSA, but it's a 2.4 kernel and a completely
different soundcard. I also decided to test some other openal programs
as well to rule out the possibility of this being a UT2004 issue. The
only program I could find quickly that used openal was chromium, so I
used that to test.

As soon as I installed chromium I tried running it and got sound. A
quick check of loaded modules showed that my OSS compatibility modules
were loaded. So I unloaded them and then tried running again. Sound
again. Then I checked the modules again, and the OSS compatibility
modules had just been loaded again. (since /dev/dsp had been probed) So
I unloaded the OSS modules and then proceeded to rename them so that
they COULDN'T be loaded. I then ran chromium again and got no sound plus
the /dev/[sound/]dsp error again. Checking /dev quickly, I noticed that
dsp is still there, which is to be expected without a udev system. So
the error I keep seeing is just related to whether or not dsp can be
used as a sound device, not necessarily whether it exists.

So the end result is that I BELIEVE that OpenAL does, in fact, require
OSS, albeit inadvertently (by always loading OSS support when it starts
up, if it's not already loaded). I am not, however, a developer for
anything using OpenAL, so I could be way off here. But these are just my
observations. So, with that in mind, what now? As far as UT2004 goes at
least, just load up OSS emulation and be happy?

Ryan, I've seen you post to openal-devel before, and you're much more
knowledgeable in all of this than I am, so any thoughts you have on the
matter would be greatly appreciated. Or, if you think it might actually
be an openal issue, I'd appreciate it if you'd bring it up my behalf.
I'd feel very much out of my league on openal-devel I'm afraid.

Alex Malinovich
Support Free Software, delete your Windows partition TODAY!
Encrypted mail preferred. You can get my public key from any of the
pgp.net keyservers. Key ID: A6D24837

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <http://icculus.org/pipermail/ut2004/attachments/20040321/ec939d52/attachment.pgp>

More information about the ut2004 mailing list