[ut2004] ALSA sound without OSS emulation

Alex Malinovich demonbane at the-love-shack.net
Thu Mar 18 18:51:42 EST 2004

On Thu, 2004-03-18 at 17:12, Aaron Gyes wrote:
> You need to create a ~/.openalrc with this in it:
> (define devices '(alsa))
> for surround sound add this:
> (define speaker-num 4)
> (define alsa-out-device "surround40:0,0")

I tried first creating it with just the first line, and then with the
surround lines as well (I'm using an SB Live!), and still nothing. I
still get the /dev/[sound/]dsp error and no sound. If I manually create
the dsp device (mknod dsp c 14 3), I get sound, but that's because the
OSS support loads and gives me sound. (doing a lsmod before and after
running the game, snd-pcm-oss is not loaded before running, but it IS
loaded after running.)

Is there anything else I can do? Is there a way to get some more verbose
log information out of UT so I can better try to troubleshoot what's
going on?

Alex Malinovich
Support Free Software, delete your Windows partition TODAY!
Encrypted mail preferred. You can get my public key from any of the
pgp.net keyservers. Key ID: A6D24837

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <http://icculus.org/pipermail/ut2004/attachments/20040318/c6b5462e/attachment.pgp>

More information about the ut2004 mailing list