[ut2004] Unplayable game after update kernel, Problem Solved.

Nathan Van Eps nathanvaneps at yahoo.com
Thu Jul 8 17:51:54 EDT 2004


I get way lower than that with glxgears (~6740), but my system is

Processor: dual Athlon MP 2800+
Memory: 1.25 gig
Video: BFG tech GeForce FX 5900XT 128meg with the 6106 drivers
Kernel: 2.6.7
Distro: Gentoo

[~]cat /proc/driver/nvidia/agp/status
Status:          Enabled
Driver:          AGPGART
AGP Rate:        4x
Fast Writes:     Enabled
SBA:             Enabled

Anybody have any ideas why I would get so much lower a score in
glxgears? Unreal Tournament 2004 runs ok, but I'm always interested in
push up the resolution and eye candy...


On Thu, 2004-07-08 at 15:07, stuartb at thelinuxlink.net wrote:
> cat /proc/drivers/nvidia/agp/status/ showed disabled!
> I had the option NvAGP set to 1. I commented it out and restarted X and I
> get AGP =4x and using AGPGART. Too bad there isn't a better way to quickly
> see this problem. glxgears now runs around 8900 instead of 5700.
> I had used the nvidia supplied agpgart without trouble for so long I
> forgot about it. If anyone else has trouble with new drivers, don't forget
> to look at agp status!
> I will send this info to the nvidia drivers forum
> Stuart
> >> stuartb at thelinuxlink.net wrote:
> >>
> >>>I had Ut2004 running well under Fedora Core2. I have a dual athlon MP
> >>>system with a FX5900 and 1.75Gb ram and dual 10,000rpm drives in raid-0.
> >>>Yesterday I updated the NVIDIA driver from 5336 to 6106, then went from
> >>> my
> >>>custom 2.6.7 kernel ( with 8k stacks) to the 2.6.6smp kernel from Fedora
> >>>(4k stacks now supported by NVIDIA) Next I noted Fedora had new Xorg
> >>> rpms
> >>>on up2date so I installed them. I started X and glxgears was around
> >>> 5800.
> >>>I tried to play ut2004 and the startup was terrible and the splash of
> >>>NVIDIA was jerky. I went to instant action and any map took forever to
> >>>load.  I killed it from a console after 2 mins. I remember problems with
> >>>MesaGL rpms and NVIDIA so I uninstalled Xorg-Mesa-LibGL rpm using
> >>> --nodeps
> >>>and reinstalled NVIDIA 6106.Same problem: tuxracer is ok glxgears is ok
> >>>but jerky display of splash logo and any map under instant action
> >>> doesn't
> >>>load after several minutes. Here is some log info:
> >>>All I see is a GL out of memory error in the ut2004 log.
> >>>How can I correct this or help someone debug this?
> >>>Stuart
> >
> > #####################cut log file stuff from original#################
> >
> >
> >>>
> >>>
> >> Did you take care of the tls libGL? I'm pretty sure you have a
> >> /usr/X11R6/lib/tls/libGL.so.1.2 file (and symlink) there. Erase those
> >> (keep the directory as some apps look for it) and try again. Usually
> >> this is enough to get things running ;)
> >>
> > Yes. There are no files in the directory but the directory exists.
> > Stuart
> >

More information about the ut2004 mailing list