UT2003 Single Player Seg Fault

Joseph Tan j.tan at softhome.net
Fri Oct 4 17:40:41 EDT 2002


Many thanks to Ryan and the rest of the Epic games team for considering
and ACTUALLY producing a Linux port of UT2003. I think you'll notch up
considerable sales, include mine in.

I have a previously unmentioned showstopper bug which I'm about to enter
into bugzilla.icculus.org. Other than a windowed display problem the
UT2003 Linux demo ran without a major issue. 

The game seg faults when I create a new single player profile in the
Linux client of UT2003 full version. I've even tried importing my
Windows client's single player save position. It recognizes but it also
seg faults on proceeding on my next mission. I get this backtrace info:

[joseph at linux ut2003-linux] ./ut2003
Xlib:  extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".

[ 1]  /lib/i686/libpthread.so.0 [0x40d68e55]
Signal: SIGSEGV [segmentation fault]

I'm using Mandrake 9.0 on a dual-Athlon 2000MP, AMD 760MP motherboard,
1GB RAM, NVIDIA Quadro 900XGL (very similar to a GF4 Ti 4600).

I'm worried that this could be a GCC 3.2 and/or GLIBC linking problem. I
haven't tried the full version on any other machine other than my home

Joseph Tan
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <http://icculus.org/pipermail/ut2003/attachments/20021005/98263c14/attachment.pgp>

More information about the ut2003 mailing list