problems on debain woody

Maik Holtkamp s-y-l at
Sat Dec 14 15:26:03 EST 2002


I tried to install UT 2003 without success. The version on the CDset
ist 2107. When installing (had some 10 trials-form different devices
ideDVD, scsi burner) everytime some files failed decompressing,

Error occurred decompressing ../BR-TwinTombs.ut2


Exiting due to error
Failed to open file /opt/ut2003/BR-TwinTombs.ut2

The files failing the decompress are randomly, sometime file x
sometimes file y. To avoid problems base on the problems I copied
the files manualy from 2 different (and different decompress
problems) dirs into each other.

When trying to start the game, it returns different errors, also
ramdomly choosen, too, e.g.

maik at syl:~ $ ut2003
Object Class Winner created in Function instead of Package


Exiting due to error


maik at syl:~ $ ut2003
LevelInfo UnrealGame.UnrealTeamInfo.AlreadyExistsEntry.ReturnValue:
Serial size mismatch: Got 1, Expected 12


Exiting due to error

Sometimes (about every 10th start) the game starts, but crashes at
looding a different level. Very seldom I can play about 1 hour.
Afterwards the swap is crowded and the speed goes down.

After the first 3-5 levels (single mode), when teamplay should
beginn (some bigger maps are shown) there is no chance to continue,
only above mentioned errors.

OK, I supposed updating could fix this problems. However, trying to
update fails with following message:

ERROR: No matching delta for /opt/games/ut2003/System/XEffects.u
The program returned an error code (3)

Crawling deja, I found direct downloadable bz2 update packages from

After untaring the archives I got:

maik at syl:/usr/local/src/ut2003 $ ls
extras  README-2126  README-2136  System  Textures  ucc  updater

I tried copying this dir into the ut2003 installation dir but it
does not fix anyting :(.

Unfortunately I do totally lack in experiances with FPS. 

Since I am not sure what to report to the bagtracking system
(installation, running, update), did not open a bug up to now.

Some words on the other hard/software:

Asus A7V 133
Athlon 1900
256 MB RAM
Asus 7100 (nvidia GF2)
Hauppauge WINTV
Pinnacle Studio DV (ieee1394)
Adaptec 2940
Soundblaster live 1024/player
D-Link 530TX

Debian woody
kernel 2.4.18 (xfs patched)
Nvidia closed source driver (tried 2960,3123,4191)
  - tried 'startx -e ut2003', too, to avoid confusion with WM

If of assistance I can give straces, or any other information,

I have no idea what else to try :( and therefore greatly appreciate
any assistance.


Sorry for length. If there is something unclear (not native
english), please let me know.

bye maik

More information about the ut2003 mailing list