[sdlsound] Flac problem on X86

Ryan C. Gordon icculus at clutteredmind.org
Sun Aug 17 01:41:46 EDT 2003

> Sorry I wasn't more specific. Flac is installed and is listed in
> playsound --decoders. I've tried flac 1.1.0 and 1.0.4 - recompiling
> SDL_sound for both versions - with no luck. I'll try to find a small
> file that I have problems with.

Sorry for the delay.

I tried the test file you sent, and it works fine for me on x86 Linux,
with both Flac 1.0.4 and Flac 1.1.0.

Other thoughts:
- Make sure SDL's audio target isn't buggy (maybe a bad audio driver?)
- Build SDL_sound from CVS.
- Perhaps your compiler is generating bad code for the FLAC decoder?
- Don't use --enable-altcvt when building SDL_sound.

I built SDL_sound and FLAC 1.1.0 with default options (just "./configure"
by itself). I'm on a Athlon system, so Flac might have been using its new
3DNow! codepath, which might decode differently than a non-athlon box.

I'm using gcc 2.95.3 and glibc 2.1.3 headers.

Don't know what else to tell you...


More information about the sdlsound mailing list