Portability

Max Horn max at quendi.de
Mon Sep 24 05:48:46 EDT 2001


>  > * SDL_sound_internal.h uses a macro _D() - bad. Names startin with an
>>  underscore are reserved for the compiler & the OS -> which is the
>>  case in OS X for _D. Change the name to e.g. DEBUG_PRINTF
>
>Ugh. We can change it from _D, but i don't like DEBUG_PRINTF...something a
>little smaller, perhaps. Let me think on this one a little.

I said "e.g" =) Use anything, but not something starting with an underscore.


>  > * "#if (defined DEBUG_CHATTER)" is quite unusual usage - normally it is
>>      #if defined(DEBUG_CHATTER)
>
>Really? I've never had trouble with it. Is it giving the MacOS X compiler
>a hard time? (Actually, in general, is #ifdef a better idea?)

First of, my compiler is gcc. this is nothing serious, just a matter 
of style. Leave it as it is if you want :)

>
>>  * how about sticking to the unix standards - "prefix" and "DESTDIR"
>>  instead of "install_prefix". There are good reasons why one wants the
>>  prefix compiled into libs to be different from the install location
>>  (packaging systems come to mind)
>
>That was just a quick hack so that there could be a "make install" target.
>It, along with the rest of the Makefile, should not be considered
>permanent.

OK :)


>
>>     warning: ANSI C forbids const or volatile functions
>>
>>  Hey, what compiler do you use I wonder? My gcc 2.95 seems to be
>>  different from yours :) Dropping -pedantic works nicely, though.
>
>Odd...that's working on gcc 2.95.2 (installed from source on
>Slackware/x86) and 2.95.3 (RPM from Mandrake/PPC). GCC's developers never
>claimed that -ansi and -pendantic caught all violations, though.

I do use gcc 2.95.2, installed with the Apple Developer Tools on Mac 
OS X :) Don't ask me why it is even more pedantic than your gcc 
build, maybe Apple added some more mods besides what is already in 
there (Apple added quite a lot of additional features).


>I'd be interested in getting a list of specifically what things make your
>GCC throw up, and if reasonable, change them in SDL_sound. If it isn't
>reasonable, we'll drop the -ansi/-pedantic flags, but I like compiling
>with as many anal warnings as possible on a given platform.

Just drop the -pedantic flag. It is not really reasonable to change 
this, esp. since many of the problems are in SDL headers, not in 
SDL_sound. You can keep the -ansi flag if you want, though, that is 
"harmless".


[...]

>Another good reason to scrap the makefile.
>
>(Seeing a pattern?  :)  )

Well, what I would say:
* you definitly want to use autoconf and libtool
* you *can* use Automake for your makefile, or you keep with your 
simple makefile.



>
>>  I do not want to make this down or anything, just list issues I
>>  encountered and suggestions on how you might overcome them. feel free
>>  to act on this as it pleases you.
>
>No, it is actually very much appreciated. Not only do we have some things
>to tackle, now, you actually took the time to try and build on a new
>platform, which is very good of you.
>
>If you get bored and want to put together some initial autoconf work for
>me, I'll gratefully accept it. Otherwise, I will get around to it, but
>it's one of those ugly jobs that I have to motivate myself to do.  :)

Sure I can do it! Will send you something as soon as I get time 
(might be today):


Max
-- 
-----------------------------------------------
Max Horn
Software Developer

email: <mailto:max at quendi.de>
phone: (+49) 6151-494890



More information about the sdlsound mailing list