[quake2] Icculus need fixes

Brendan Burns brendanburns at comcast.net
Sat Apr 2 22:06:54 EST 2005

Any binary-only mods won't work with Icculus q2, that's just the way it 
is.  There are changes to the game's internals structures that preclude 
them working with binary only mods.    If complete source is available 
for the mod they can be recompiled and they should work just fine with 
icculus q2.

On the other hand, id's q2 doesn't support joysticks, retexturing, or 
any of the other features people have added into the code base over the 
years (including a number of security fixes) so its a trade-off between 
mod compatibility and other improvements

The only "fix" that would allow better mod compatibility would be some 
sort of glue code that adapts old game.so's to work with icculus q2.  
Anyone who wants to code and contribute that is welcome to do so...  (I 
have many, many more pressing engagements...)

I hope that helps explain the situation.

On Apr 2, 2005, at 8:37 PM, qudos qudos wrote:

> Hi,
> Sorry but something is wrong inside the q2 icculus source.
> I'd installed the official 3.20 binaries from idsoftware, thanks to a
> good friend, which was my surprise, a lot of mods not working in the
> q2-icculus are working with no problems in 3.20-id.
> This are Lithium, Gladiator, Eraser, lmctf,.........
> I don't know what is happening, but plz team, stop right now and try
> to fix the main q2-icculus code. Is a great project, but sometimes
> useless.
> Today is too late to test more mods and stuff.
> Cheers.

More information about the quake2 mailing list