[physfs] Compiling PhysicsFS 1.0.X under msys (zlib installed)

Bjørn Lindeijer bjorn at lindeijer.nl
Mon Oct 23 08:57:01 EDT 2006

On 10/23/06, Anthony Cassidy <anthonytcassidy at hotmail.com> wrote:
> Hey peoples
> I am trying to compile physicsfs so that I can build
> http://themanaworld.org/,
> I managed to get version 1.1.0 to compile, but unfortunately mana world
> needs
> 1.0.X, i have tried both 1.0.0 and 1.0.1, and I am getting the same error
> i:\msys\1.0\bin\..\lib\gcc\mingw32\3.4.2\..\..\..\..\mingw32\bin\ld.exe:
> warning: cannot find entry symbol _DllMainCRTStartup at 12; defaulting to
> 00401000
> i:/msys/1.0/bin/../lib/gcc/mingw32/3.4.2/../../../libmingw32.a(main.o)(.text+0x106):main.c:
> undefined reference to `WinMain at 16'

Note that The Mana World needs 1.0.x because a bug in the 1.1.0
release causes it to crash. I think this bug has already been fixed in
the development version of PhysFS a long time ago, so you might also
try to compile that instead.


More information about the physfs mailing list