Physfs ABI

Matze Braun matze at
Thu Sep 8 06:20:47 EDT 2005


With physfs 1.1 the library name on unix/linux has been changed to thus indicating to the linux linker that version 1.1
is a completely different library than 1.0, so that in effect you have
to relink all the apps that were linked against physfs 1.0.

Though when I look at the lib it seems that version 1.1.0 only added
some new functions and that the ABI should be backwards compatible. If
it is like that, could you please use some different naming scheme so
that the linker will recognize it?


More information about the physfs mailing list