[openbox] trouble compiling

Tomasek, Kevin ktomasek at intersil.com
Wed Nov 26 17:20:16 EST 2008

if i search glib (gtk)  the newest revision is 2.18..  this too would
fail as it is below 2.6.
there must be some other fact we are missing..


From: Dave Foster [mailto:daf at minuslab.net] 
Sent: Wednesday, November 26, 2008 3:46 PM
To: openbox at icculus.org
Subject: Re: [openbox] trouble compiling

Tomasek, Kevin wrote: 

	ktomasek at d2al220 <mailto:ktomasek at d2al220>
/tmp/openbox-[39]>which pkg-config
	ktomasek at d2al220 <mailto:ktomasek at d2al220>
/tmp/openbox-[40]>eg PKG
	ktomasek at d2al220 <mailto:ktomasek at d2al220>
/tmp/openbox-[41]>uname -a
	Linux d2al220 2.6.9-34.0.2.ELsmp #1 SMP Fri Jul 7 18:22:55 CDT
2006 x86_64 x86_64 x86_64 GNU/Linux
	from the results of uname, it seems that i am running a version
of glib which is greater than 2.6.  why is configure having a problem
with this??

glibc is no the same thing as glib, at all.

	here is the configure command line:
	./configure --prefix=/usr/local --libdir=/usr/lib64  
	how is one to know what value GLIB_CFLAGS should be set to?

your glib is too old.  you need to update it.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://icculus.org/pipermail/openbox/attachments/20081126/a761ba79/attachment.htm>

More information about the openbox mailing list