[mojosetup] [7/13] Simplify the rollback log messages.

Francois Gouget fgouget at codeweavers.com
Mon May 21 14:05:10 EDT 2012


This makes the log more readable without losing important information.
---

This is obviously not strictly needed but given that the path of the 
rollback can be deduced from its id it seems redundant to print it too.

 scripts/mojosetup_mainline.lua |    4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/scripts/mojosetup_mainline.lua b/scripts/mojosetup_mainline.lua
index e60bdb6..95163b0 100644
--- a/scripts/mojosetup_mainline.lua
+++ b/scripts/mojosetup_mainline.lua
@@ -220,7 +220,7 @@ local function do_rollbacks()
                              _("Couldn't restore some files. Your existing installation is likely damaged."))
             warned = true
         end
-        MojoSetup.loginfo("Restored rollback #" .. id .. ": '" .. src .. "' -> '" .. dest .. "'")
+        MojoSetup.loginfo("Restored rollback #" .. id .. ": '" .. dest .. "'")
     end
 
     MojoSetup.rollbacks = {}   -- just in case this gets called again...
@@ -523,7 +523,7 @@ local function backup_file(path)
     if not MojoSetup.movefile(path, f) then
         MojoSetup.fatal(_("Couldn't backup '" .. path .. "' to '" .. f .. "' for rollback"))
     end
-    MojoSetup.loginfo("Moved rollback #" .. id .. ": '" .. path .. "' -> '" .. f .. "'")
+    MojoSetup.loginfo("Created rollback #" .. id .. ": '" .. path .. "'")
 end
 
 
-- 
1.7.10


More information about the mojosetup mailing list