[lokisetup] [PATCH] more control over static/dynamic linking

Stephane Peter megastep at megastep.org
Wed Dec 15 19:06:09 EST 2004

OK, well since we did have code making use of GPM, I just fixed the 
detection so that it may be used. After all it is quite a useful 
feature of the dialog code that is there, and I see no compelling 
reason to remove it.

On Dec 15, 2004, at 3:07 PM, Ludwig Nussel wrote:

> Stephane Peter wrote:
>> OK cool, I think I'll merge this, hoping it doesn't break non-Linux
>> support, which I really need to be functional. I also need all of 
>> these
>> to be static by default (even ncurses), if you don't mind.
> Ok. There is a useless dependency on libgpm. configure checks libgpm
> and adds -lgpm but doesn't define HAVE_LIBGPM. I'd just remove the
> gpm checks as apparently noone missed gpm support.
> JFYI loki-setup doesn't build on biarch architectures
> (x86_64,ppc64,s390x) by default. One needs to export LIBSUFFIX=64.
> It probably doesn't make sense to add checks for this to configure
> as some distributions do not follow the lib/lib64 convention.
> cu
> Ludwig
> -- 
> (o_  Ludwig.Nussel at gmx.de
> //\
> V_/_ PGP Key ID: FF8135CE
> <loki_setup.diff>
Stéphane Peter
megastep at megastep.org

More information about the Lokisetup mailing list