[lokisetup] xsu broken?

John Quigley jmquigs at bigfoot.com
Thu Apr 10 00:21:55 EDT 2003


./xsu -e -a -u root -c "/usr/X11R6/bin/xterm"


On Wednesday 09 April 2003 9:14 pm, John Quigley wrote:
> It sorta works for me.  If I run
> ./xsu -e -a -u root -c "touch it"
> I get a root-owned "it" file.  But if I run
> ./xsu -e -a -u root -c "xterm"
> I don't get an xterm.  (Even if I set DISPLAY env)  Running on gentoo now
> but I built xsu on my redhat 7.3 box.
> On Wednesday 09 April 2003 8:12 pm, Stéphane Peter wrote:
> > I have been using the current xsu from CVS for quite some time, and at
> > least on Linux it seems stable enough. Are you running this maybe on a
> > newer distribution ?
> >
> > > Can anyone successfully run the current xsu binary? It fails here, both
> > > with a local build and the holy box build of xsu. I get the dialog, I
> > > enter the command and the user information, then I see an su process
> > > spawned. And nothing happens, + su doesn't exit.

More information about the Lokisetup mailing list