more menuitem voodoo

John Quigley jmquigs at
Sat Apr 5 18:13:47 EST 2003

I found that when I ran setup on my gentoo box, I couldn't get KDE menuitems 
to show up when I ran the installer as myself or as root.

For my user, the problem was that some other installer (looks like openoffice) 
had created a ~/.kde2 directory, which setup was using for the menuitems.  
But, my version of kde (3.1.1) only looks in ~/.kde, not ~/.kde2.  So I 
changed setup to look for .kde first, then kde2 and kde3

For root, the problem was the /usr/share/gnome/apps in the RedHat 
configuration.  This directory exists on my system, so setup put the 
menuitems in there (and then did not install any more items, since a 
successful redhat is supposed to take care of everything).  So naturally this 
didn't show up on my KDE menu.  I fixed this by removing 
/usr/share/gnome/apps from redhat (its is also in the Gnome configuration, so 
that should take care of it in non-redhat cases).

Attached is a patch which fixes these problems for me.  Really hope that 
someday everybody uses one desktop menuitem convention (or even a few 
_standard_ conventions).  Ha.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: setup-install.c.patch
Type: text/x-diff
Size: 1016 bytes
Desc: not available
URL: <>

More information about the Lokisetup mailing list